# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*\S)?\s*$/$1,/gm;t' <<< " foo dog
bar cat
foo bar bird
bar rodent
frog foo fish
"