package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*\S)?\s*$`)
var str = ` foo dog
bar cat
foo bar bird
bar rodent
frog foo fish
`
var substitution = "$1,"
fmt.Println(re.ReplaceAllString(str, substitution))
}