use strict;
my $str = ' foo dog
bar cat
foo bar bird
bar rodent
frog foo fish
';
my $regex = qr/^(.*\S)?\s*$/mp;
my $subst = '$1,';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";