#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*\S)?\s*$"
Local $sString = " foo dog " & @CRLF & _
" bar cat " & @CRLF & _
" foo bar bird" & @CRLF & _
" bar rodent " & @CRLF & _
" frog foo fish" & @CRLF & _
""
Local $sSubst = "$1,"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)