$re = '/^(.*\S)?\s*$/m';
$str = ' foo dog
bar cat
foo bar bird
bar rodent
frog foo fish
';
$subst = "$1,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;