// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*\S)?\s*$").unwrap();
let string = " foo dog
bar cat
foo bar bird
bar rodent
frog foo fish
";
let substitution = "$1,";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}