re = /^(.*\S)?\s*$/m
str = ' foo dog
bar cat
foo bar bird
bar rodent
frog foo fish
'
subst = '$1,'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result