using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*\S)?\s*$";
string substitution = @"$1,";
string input = @" foo dog
bar cat
foo bar bird
bar rodent
frog foo fish
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}