import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*\\S)?\\s*$";
final String string = " foo dog \n"
+ " bar cat \n"
+ " foo bar bird\n"
+ " bar rodent \n"
+ " frog foo fish\n";
final String subst = "$1,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}