const regex = /^(.*\S)?\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*\\S)?\\s*$', 'gm')
const str = ` foo dog
bar cat
foo bar bird
bar rodent
frog foo fish
`;
const subst = `$1,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);