#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\\")([^\\n]*)(\\n)([^\\n]*)(\\")"
Local $sString = "companyaddress2\r\nmultiple1,\"my address row 1\nmy address row 2\",12345,\"my address 22222 row 1\nmy address 2222 row 2\"\r\n"
Local $sSubst = "$2 $4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)