// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(\\")([^\\n]*)(\\n)([^\\n]*)(\\")"#).unwrap();
let string = "companyaddress2\\r\\nmultiple1,\\\"my address row 1\\nmy address row 2\\\",12345,\\\"my address 22222 row 1\\nmy address 2222 row 2\\\"\\r\\n";
let substitution = "$2 $4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}