import Foundation
let pattern = #"(\\")([^\\n]*)(\\n)([^\\n]*)(\\")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"companyaddress2\r\nmultiple1,\"my address row 1\nmy address row 2\",12345,\"my address 22222 row 1\nmy address 2222 row 2\"\r\n"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2 $4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)