import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\\\\")([^\\\\n]*)(\\\\n)([^\\\\n]*)(\\\\\")";
final String string = "companyaddress2\\r\\nmultiple1,\\\"my address row 1\\nmy address row 2\\\",12345,\\\"my address 22222 row 1\\nmy address 2222 row 2\\\"\\r\\n";
final String subst = "$2 $4";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}