re = /(\\")([^\\n]*)(\\n)([^\\n]*)(\\")/
str = 'companyaddress2\\r\\nmultiple1,\\"my address row 1\\nmy address row 2\\",12345,\\"my address 22222 row 1\\nmy address 2222 row 2\\"\\r\\n'
subst = '$2 $4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result