const regex = /(\\")([^\\n]*)(\\n)([^\\n]*)(\\")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\\")([^\\\\n]*)(\\\\n)([^\\\\n]*)(\\\\")', 'g')
const str = `companyaddress2\\r\\nmultiple1,\\"my address row 1\\nmy address row 2\\",12345,\\"my address 22222 row 1\\nmy address 2222 row 2\\"\\r\\n`;
const subst = `$2 $4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);