# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[.+](?=[^\s@]*@gmail\.com)//gm;t' <<< "john.brian@gmail.com
henix..mail+@gmail.com
sar+ah+.black+.+@gmail.com"