const regex = /[.+](?=[^\s@]*@gmail\.com)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[.+](?=[^\\s@]*@gmail\\.com)', 'gm')
const str = `john.brian@gmail.com
henix..mail+@gmail.com
sar+ah+.black+.+@gmail.com`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);