use strict;
my $str = 'john.brian@gmail.com
henix..mail+@gmail.com
sar+ah+.black+.+@gmail.com';
my $regex = qr/[.+](?=[^\s@]*@gmail\.com)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";