import re
regex = re.compile(r"[.+](?=[^\s@]*@gmail\.com)", flags=re.MULTILINE)
test_str = ("john.brian@gmail.com\n"
"henix..mail+@gmail.com\n"
"sar+ah+.black+.+@gmail.com")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)