#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[.+](?=[^\s@]*@gmail\.com)"
Local $sString = "john.brian@gmail.com" & @CRLF & _
"henix..mail+@gmail.com" & @CRLF & _
"sar+ah+.black+.+@gmail.com"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)