import Foundation
let pattern = #"[.+](?=[^\s@]*@gmail\.com)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
john.brian@gmail.com
henix..mail+@gmail.com
sar+ah+.black+.+@gmail.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)