using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[.+](?=[^\s@]*@gmail\.com)";
string substitution = @"";
string input = @"john.brian@gmail.com
henix..mail+@gmail.com
sar+ah+.black+.+@gmail.com";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}