$re = '/[.+](?=[^\s@]*@gmail\.com)/m';
$str = 'john.brian@gmail.com
henix..mail+@gmail.com
sar+ah+.black+.+@gmail.com';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;