# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b[A-Z]_([a-zA-Z0-9])/\1/g;t' <<< "(X_xy09 and X_foobar or (X_abc123 and X_something))"