re = /\b[A-Z]_([a-zA-Z0-9])/
str = '(X_xy09 and X_foobar or (X_abc123 and X_something))'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result