#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b[A-Z]_([a-zA-Z0-9])"
Local $sString = "(X_xy09 and X_foobar or (X_abc123 and X_something))"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)