import re
regex = re.compile(r"\b[A-Z]_([a-zA-Z0-9])")
test_str = "(X_xy09 and X_foobar or (X_abc123 and X_something))"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)