package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[A-Z]_([a-zA-Z0-9])`)
var str = `(X_xy09 and X_foobar or (X_abc123 and X_something))`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}