using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[A-Z]_([a-zA-Z0-9])";
string substitution = @"\1";
string input = @"(X_xy09 and X_foobar or (X_abc123 and X_something))";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}