# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/from (\w+);$/from $1 where 1000 <= (select count(1) from $1);/gm;t' <<< "Create new-table1 ... As select ..from table1;
Create new-table2 ... As select ..from table2;
Create new-table3 ... As select ..from table3;"