import Foundation
let pattern = #"from (\w+);$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Create new-table1 ... As select ..from table1;
Create new-table2 ... As select ..from table2;
Create new-table3 ... As select ..from table3;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"from $1 where 1000 <= (select count(1) from $1);"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)