package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)from (\w+);$`)
var str = `Create new-table1 ... As select ..from table1;
Create new-table2 ... As select ..from table2;
Create new-table3 ... As select ..from table3;`
var substitution = "from $1 where 1000 <= (select count(1) from $1);"
fmt.Println(re.ReplaceAllString(str, substitution))
}