#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)from (\w+);$"
Local $sString = "Create new-table1 ... As select ..from table1;" & @CRLF & _
"Create new-table2 ... As select ..from table2;" & @CRLF & _
"Create new-table3 ... As select ..from table3;"
Local $sSubst = "from $1 where 1000 <= (select count(1) from $1);"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)