const regex = /from (\w+);$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('from (\\w+);$', 'gm')
const str = `Create new-table1 ... As select ..from table1;
Create new-table2 ... As select ..from table2;
Create new-table3 ... As select ..from table3;`;
const subst = `from $1 where 1000 <= (select count(1) from $1);`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);