re = /from (\w+);$/m
str = 'Create new-table1 ... As select ..from table1;
Create new-table2 ... As select ..from table2;
Create new-table3 ... As select ..from table3;'
subst = 'from $1 where 1000 <= (select count(1) from $1);'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result