import re
regex = re.compile(r"from (\w+);$", flags=re.MULTILINE)
test_str = ("Create new-table1 ... As select ..from table1;\n"
"Create new-table2 ... As select ..from table2;\n"
"Create new-table3 ... As select ..from table3;")
subst = "from $1 where 1000 <= (select count(1) from $1);"
result = regex.sub(subst, test_str)
if result:
print(result)