import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "from (\\w+);$";
final String string = "Create new-table1 ... As select ..from table1;\n"
+ "Create new-table2 ... As select ..from table2;\n"
+ "Create new-table3 ... As select ..from table3;";
final String subst = "from $1 where 1000 <= (select count(1) from $1);";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}