// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)from (\w+);$").unwrap();
let string = "Create new-table1 ... As select ..from table1;
Create new-table2 ... As select ..from table2;
Create new-table3 ... As select ..from table3;";
let substitution = "from $1 where 1000 <= (select count(1) from $1);";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}