# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/
(?:
( > ) # (1)
old [ ] string
( < ) # (2)
|
( " ) # (3)
old [ ] string
( " ) # (4)
|
( ' ) # (5)
old [ ] string
( ' ) # (6)
|
( \( ) # (7)
old [ ] string
( \) ) # (8)
)
/\1\3\5\7new string\2\4\6\8/gmx;t' <<< "(old string) 'old string' old string >old string<
\"old string\" >old string< old string 'old string'
"