import Foundation
let pattern = ##"""
(?:
( > ) # (1)
old [ ] string
( < ) # (2)
|
( " ) # (3)
old [ ] string
( " ) # (4)
|
( ' ) # (5)
old [ ] string
( ' ) # (6)
|
( \( ) # (7)
old [ ] string
( \) ) # (8)
)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
(old string) 'old string' old string >old string<
"old string" >old string< old string 'old string'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\3\5\7new string\2\4\6\8"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)