package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)
(?:
( > ) # (1)
old [ ] string
( < ) # (2)
|
( " ) # (3)
old [ ] string
( " ) # (4)
|
( ' ) # (5)
old [ ] string
( ' ) # (6)
|
( \( ) # (7)
old [ ] string
( \) ) # (8)
)
`)
var str = `(old string) 'old string' old string >old string<
"old string" >old string< old string 'old string'
`
var substitution = "\1\3\5\7new string\2\4\6\8"
fmt.Println(re.ReplaceAllString(str, substitution))
}