using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"
(?:
( > ) # (1)
old [ ] string
( < ) # (2)
|
( "" ) # (3)
old [ ] string
( "" ) # (4)
|
( ' ) # (5)
old [ ] string
( ' ) # (6)
|
( \( ) # (7)
old [ ] string
( \) ) # (8)
)
";
string substitution = @"\1\3\5\7new string\2\4\6\8";
string input = @"(old string) 'old string' old string >old string<
""old string"" >old string< old string 'old string'
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}