// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mx)
(?:
( > ) # (1)
old [ ] string
( < ) # (2)
|
( " ) # (3)
old [ ] string
( " ) # (4)
|
( ' ) # (5)
old [ ] string
( ' ) # (6)
|
( \( ) # (7)
old [ ] string
( \) ) # (8)
)
"#).unwrap();
let string = "(old string) 'old string' old string >old string<
\"old string\" >old string< old string 'old string'
";
let substitution = "\\1\\3\\5\\7new string\\2\\4\\6\\8";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}