# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?:
( > ) # (1)
old [ ] string
( < ) # (2)
|
( " ) # (3)
old [ ] string
( " ) # (4)
|
( ' ) # (5)
old [ ] string
( ' ) # (6)
|
( \( ) # (7)
old [ ] string
( \) ) # (8)
)
"""
test_str = ("(old string) 'old string' old string >old string<\n"
"\"old string\" >old string< old string 'old string'\n")
subst = "\\1\\3\\5\\7new string\\2\\4\\6\\8"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.