use strict;
my $str = '(old string) \'old string\' old string >old string<
"old string" >old string< old string \'old string\'
';
my $regex = qr/
(?:
( > ) # (1)
old [ ] string
( < ) # (2)
|
( " ) # (3)
old [ ] string
( " ) # (4)
|
( ' ) # (5)
old [ ] string
( ' ) # (6)
|
( \( ) # (7)
old [ ] string
( \) ) # (8)
)
/mxp;
my $subst = '\\1\\3\\5\\7new string\\2\\4\\6\\8';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";