$re = '/
(?:
( > ) # (1)
old [ ] string
( < ) # (2)
|
( " ) # (3)
old [ ] string
( " ) # (4)
|
( \' ) # (5)
old [ ] string
( \' ) # (6)
|
( \( ) # (7)
old [ ] string
( \) ) # (8)
)
/mx';
$str = '(old string) \'old string\' old string >old string<
"old string" >old string< old string \'old string\'
';
$subst = "\1\3\5\7new string\2\4\6\8";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;