#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mx) " & @CRLF & _
" (?:" & @CRLF & _
" ( > ) # (1)" & @CRLF & _
" old [ ] string" & @CRLF & _
" ( < ) # (2)" & @CRLF & _
" | " & @CRLF & _
" ( " ) # (3)" & @CRLF & _
" old [ ] string" & @CRLF & _
" ( " ) # (4)" & @CRLF & _
" | " & @CRLF & _
" ( ' ) # (5)" & @CRLF & _
" old [ ] string" & @CRLF & _
" ( ' ) # (6)" & @CRLF & _
" | " & @CRLF & _
" ( \( ) # (7)" & @CRLF & _
" old [ ] string " & @CRLF & _
" ( \) ) # (8)" & @CRLF & _
" )" & @CRLF & _
""
Local $sString = "(old string) 'old string' old string >old string<" & @CRLF & _
""old string" >old string< old string 'old string'" & @CRLF & _
""
Local $sSubst = "\1\3\5\7new string\2\4\6\8"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)