import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " \n"
+ " (?:\n"
+ " ( > ) # (1)\n"
+ " old [ ] string\n"
+ " ( < ) # (2)\n"
+ " | \n"
+ " ( \" ) # (3)\n"
+ " old [ ] string\n"
+ " ( \" ) # (4)\n"
+ " | \n"
+ " ( ' ) # (5)\n"
+ " old [ ] string\n"
+ " ( ' ) # (6)\n"
+ " | \n"
+ " ( \\( ) # (7)\n"
+ " old [ ] string \n"
+ " ( \\) ) # (8)\n"
+ " )\n";
final String string = "(old string) 'old string' old string >old string<\n"
+ "\"old string\" >old string< old string 'old string'\n";
final String subst = "\\1\\3\\5\\7new string\\2\\4\\6\\8";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}