# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<link>(\w*)<\\/link>/<a href="tooltip('\1')">\1<\/a>/gm;t' <<< "This is a sample text containing a link <link>testlink</link>. And another link <link>testlink2</link>"